Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic Webserver startet nicht unter Win 2003 (Read 3550 times)
MisterT
Guest


Webserver startet nicht unter Win 2003
12. Dec 2004 at 19:01
Print Post  
Hallo,
ich kann den Webserver unter Windows 2003 Server nicht starten Sad
Im Debug Fenster steht folgendes:
Code
Select All
18:51:59,867: Exception: WSocketResolveProto: Cannot convert protocol 'tcp', Error #11004
18:51:59,867:   77E449CE: kernel32.dll - RaiseException
18:51:59,867:   004F6899: phoner.exe - WSocketResolveProto
18:51:59,867:   004F7972: phoner.exe - TCustomWSocket.Listen
18:51:59,867:   004F94A0: phoner.exe - TCustomSocksWSocket.Listen
18:51:59,867:   004FC917: phoner.exe - THttpServer.Start
18:51:59,867:   0053F347: phoner.exe - WebServerStartStop
18:51:59,867:   0053F4C3: phoner.exe - TfrmWeb.btOKClick
18:51:59,867:   00479BA1: phoner.exe - TControl.Click
18:51:59,867:   0047CA67: phoner.exe - TWinControl.WndProc
18:51:59,867:   0047CB9F: phoner.exe - DoControlMsg
18:51:59,867:   0047CA67: phoner.exe - TWinControl.WndProc
18:51:59,867:   0047C6E2: phoner.exe - TWinControl.MainWndProc
18:51:59,867:   00425DE1: phoner.exe - StdWndProc
18:51:59,867:   77CD612A: user32.dll -
18:51:59,867:   77CD69A0: user32.dll - GetMessageW
18:51:59,867:   77CD8816: user32.dll - MapWindowPoints
18:51:59,867:   77CD8878: user32.dll - SendMessageW
18:51:59,867:   70AF5431: comctl32.dll - Ordinal384
18:51:59,867:   77CD612A: user32.dll -
18:51:59,867:   77CD69A0: user32.dll - GetMessageW
18:51:59,867:   77CD8ED7: user32.dll - GetDlgItem
18:51:59,867:   77CD9B75: user32.dll - CallWindowProcA
18:51:59,867:   0047CB4B: phoner.exe - TWinControl.DefaultHandler
18:51:59,867:   0047CA67: phoner.exe - TWinControl.WndProc
18:51:59,867:   00425DE1: phoner.exe - StdWndProc
18:51:59,867:   77CD612A: user32.dll -
18:51:59,867:   77CD69A0: user32.dll - GetMessageW
18:51:59,867:   77CD6684: user32.dll - TranslateMessage
18:51:59,867:   77CDFADF: user32.dll - DispatchMessageA
18:51:59,867:   0056F4A7: phoner.exe - Phoner
18:51:59,867:   77E2F387: kernel32.dll - TerminateThread
18:51:59,877: Exception: listen: WSocketResolveProto: Cannot convert protocol 'tcp', Error #11004
18:51:59,877:   77E449CE: kernel32.dll - RaiseException
18:51:59,877:   004F4065: phoner.exe - TCustomWSocket.RaiseException
18:51:59,877:   004F7A70: phoner.exe - TCustomWSocket.Listen
18:51:59,877:   004F94A0: phoner.exe - TCustomSocksWSocket.Listen
18:51:59,877:   004FC917: phoner.exe - THttpServer.Start
18:51:59,877:   0053F347: phoner.exe - WebServerStartStop
18:51:59,877:   0053F4C3: phoner.exe - TfrmWeb.btOKClick
18:51:59,877:   00479BA1: phoner.exe - TControl.Click
18:51:59,877:   0047CA67: phoner.exe - TWinControl.WndProc
18:51:59,877:   0047CB9F: phoner.exe - DoControlMsg
18:51:59,877:   0047CA67: phoner.exe - TWinControl.WndProc
18:51:59,877:   0047C6E2: phoner.exe - TWinControl.MainWndProc
18:51:59,877:   00425DE1: phoner.exe - StdWndProc
18:51:59,877:   77CD612A: user32.dll -
18:51:59,877:   77CD69A0: user32.dll - GetMessageW
18:51:59,877:   77CD8816: user32.dll - MapWindowPoints
18:51:59,877:   77CD8878: user32.dll - SendMessageW
18:51:59,877:   70AF5431: comctl32.dll - Ordinal384
18:51:59,877:   77CD612A: user32.dll -
18:51:59,877:   77CD69A0: user32.dll - GetMessageW
18:51:59,877:   77CD8ED7: user32.dll - GetDlgItem
18:51:59,877:   77CD9B75: user32.dll - CallWindowProcA
18:51:59,877:   0047CB4B: phoner.exe - TWinControl.DefaultHandler
18:51:59,877:   0047CA67: phoner.exe - TWinControl.WndProc
18:51:59,877:   00425DE1: phoner.exe - StdWndProc
18:51:59,877:   77CD612A: user32.dll -
18:51:59,877:   77CD69A0: user32.dll - GetMessageW
18:51:59,877:   77CD6684: user32.dll - TranslateMessage
18:51:59,877:   77CDFADF: user32.dll - DispatchMessageA
18:51:59,877:   0056F4A7: phoner.exe - Phoner
18:51:59,877:   77E2F387: kernel32.dll - TerminateThread
18:51:59,877: Webserver not started
 


Leider sagt mir das gar nichts.
Zudem kann ich keine Emails versenden, da ich jedesmal den Error (500) bekomme.
Das ganze auf einem XP PC funktioniert ohne Probleme.
Es soll aber unbedingt auf der Win 2003 Kiste laufen.

MisterT
  
Back to top
 
IP Logged
 
MisterT
Guest


Re: Webserver startet nicht unter Win 2003
Reply #1 - 12. Dec 2004 at 19:53
Print Post  
Ok,
habe mal etwas gegoogelt und hier die Lösung aller Probleme (gefunden in einem anderen Forum):
Quote:

Hi, 

da auch andere Programme vermutlich bei dir Fehler verursachen werden, helfe ich Dir trotzdem mal (und anderen die das Problem haben). 
Ich programmiere selbst und verwende dabei WSocket. Ein bekannter stieß mit meinem Programm dann auf dasselbe problem, nachdem er XP SP 2 installiert und wieder deinstalliert hatte (hat ihm nicht gefallen). Aber nicht nur mein Programm mit WSocket, sondern auch andere wie z.B. der MSN-Messenger konnten keine Verbindungen mehr aufbauen. 
Habe mich dann an den Programmierer von WSocket gewandt und der sagte mir folgendes: Das SP2 spielt irgendwie am TCP-Stack rum. TCP-Stack resetten und dann geht es wieder. Und tatsächlich - mein Bekannter hat es ausprobiert, und nun funktionieren alle Programme wieder. 
Wie resettet man also den TCP-Stack ? 
-> Start -> Ausführen -> "cmd" 

dort gibt man ein 
netsh int ip reset C:\Reset.log 

Der letzte Parameter kann beliebig geändert werden - er gibt an, wo die Log-Datei gespeichert wird, in der steht, ob alles gut funktioniert hat. 

Nach Ausführen des o.g. Befehls sollte die Log-Datei geschrieben worden sein und man kann in dieser nachschauen, ob alles glatt gelaufen ist. Nun nur noch den PC neu starten und alles sollte wieder gehen. 


MisterT
  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 10210
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Webserver startet nicht unter Win 2003
Reply #2 - 26. Dec 2004 at 13:29
Print Post  
Und nun funktioniert es? Das ist in der Tat interessant.
Phoner verwendet auch die TWSockets...
  
Back to top
WWW  
IP Logged
 
MisterT
Guest


Re: Webserver startet nicht unter Win 2003
Reply #3 - 01. Jan 2005 at 14:38
Print Post  
Ja, nun funktioniert wieder alles.
Da hatte wohl irgendein Windows Update zu viel des guten getan.
Aber nach dem besagten Befehl ist alles wieder 1a.

MisterT
  
Back to top
 
IP Logged
 
Badgauzi
Guest


Re: Webserver startet nicht unter Win 2003
Reply #4 - 10. Jan 2005 at 14:30
Print Post  
Hy Leute!

Hatte eben auch die gleiche Fehlermeldung, allerdings "nur" bei meinen FTP-Server. Der konnte einfach nicht starten. Habe diese Reset durchgeführt und es funkt. bei mir auch wieder alles.

DANKE - für diesen spitzen Tipp!!!! Grin Grin Grin Grin Grin
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint