Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic Phoner Lite: kein Ton beim angerufenen (Read 25064 times)
Pfeffer
Guest


Phoner Lite: kein Ton beim angerufenen
30. Jul 2005 at 16:07
Print Post  
wählen funktionert. Es klingelt. Verbindung wird aufgebaut. STUN hat geklappt, zeigt der Ethereal-Trace. Es werden in beide Richtungen rtp-Daten übertragen. Nur: Die Daten, die Phoner Lite sendet, sind leer.  Die rtp-Nutzedaten im g.726-32-Protokoll enthalt einfach immer ff, sonst nichts.

Gruß,
  Pfeffer.
  
Back to top
 
IP Logged
 
Suppenkasper
God Member
*****
Offline


Phoner-Support

Posts: 1536
Location: Aachen
Joined: 29. Mar 2005
Gender: Male
Re: Phoner Lite: kein Ton beim angerufenen
Reply #1 - 30. Jul 2005 at 16:28
Print Post  
Hallo Pfeffer,

Du machst leider zu wenige Angaben zum Thema; es ist leider nicht nachvollziehbar, wo der Grund für Deine Probleme liegen könnte.

Bitte lese Dir diesen Beitrag einmal durch, und beantworte die Fragen möglichst vollständig. Hierbei brauchst Du als Nutzer von PhonerLite lediglich ausser den allgemeinen Hinweisen diejenigen zu beachten, die auf den SIP-Modus zutreffen.

Dann schauen wir 'mal weiter...

Viele Grüße vom Kai
« Last Edit: 04. Oct 2005 at 12:27 by Suppenkasper »  
Back to top
IP Logged
 
Pfeffer
Guest


Re: Phoner Lite: kein Ton beim angerufenen
Reply #2 - 30. Jul 2005 at 17:29
Print Post  
1. Welche Phoner-Version wird genutzt? (Aktuelle Version: hier).   
lite.

2. Mit welcher Windows-Version wird Phoner benutzt (inkl. SP)? 
XP mit SP-2 und allen sicherheits-updates.

4. Rechnertyp, Prozessor, Speicher, z. B. AMD Duron, 1GHz, 248 MB 
AMD XP 2000+ 1024 GB RAM

5. Ist die genutzte Soundkarte full-duplexfähig? 
ja. 
Es funktioniert mit dem "richtigen" Phoner.

Noch ein Hinweis: Die Sprachqualität ist mit dem "richtigen" Phoner v1.74 hervorragend. Mit der "Lite"-version habe ich Aussetzer. (hören kann ich ja).
Irgendetwas muss mit dem Modul nicht stimmen, dass die Daten von der Soundkarte (dem Mikro) holt. Denn unabhängig von dem verwendeten Codec wird korrekt eine Verbindung aufgebaut, Poner Lite zeigt an: "in: g.711, out: g.711" in oder "in: gsm, out: gsm". 

Hmm - ich habe nochmal einen Ehterreal-Trace gamacht und ihn mir diesmal vollständig angeschaut: nach 10 rtp-Paketen hört Phoner-Lite auf, rtp-Pakete raus zu schicken Sad
Die ersten 10 gehen aber korrekt raus.  der Etherreal-Trace zeigt auch, dass auf den richtigen UDP-Ports rtp-Daten hin- (die ersten 10 Pakte = bei g711 weniger als 1 Sekunde) und her übertragen werden. 

Vielleicht hilft diese Ausgabe aus dem Debug-Fenster was?
--------------
17:24:53,557: R: 217.10.79.9:5060
SIP/2.0 200 OK
Via: SIP/2.0/UDP 62.143.117.XX:61046;branch=z9hG4bK0020bebb7bffd9118016005056c00008
Record-Route: <sip:498001507090@217.10.79.8;ftag=4555;lr=on>
Record-Route: <sip:08001507090@217.10.79.9;ftag=4555;lr=on>
From: r <sip:800XXXX@sipgate.de>;tag=4555
To: <sip:08001507090@sipgate.de>;tag=as41dc2e51
Call-ID: 808925BB-7BFF-D911-8015-005056C00008@62.143.117.XX
CSeq: 10 INVITE
User-Agent: sipgate asterisk
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER
Contact: <sip:498001507090@217.10.67.4>
Content-Type: application/sdp
Content-Length: 465

v=0
o=root 17599 17600 IN IP4 217.10.67.4
s=session
c=IN IP4 217.10.67.4
t=0 0
m=audio 17230 RTP/AVP 8 0 3 97 18 2 4 5 110 7 10 101
a=rtpmap:8 PCMA/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:3 GSM/8000
a=rtpmap:97 iLBC/8000
a=rtpmap:18 G729/8000
a=rtpmap:2 G726-32/8000
a=rtpmap:4 G723/8000
a=rtpmap:5 DVI4/8000
a=rtpmap:110 speex/8000
a=rtpmap:7 LPC/8000
a=rtpmap:10 L16/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=silenceSupp:off - - - -
-------------------------------------------
17:24:53,877: Connect Active Indication: 0F 00 01 00 03 82 64 05 01 01 00 00 00 00 00 
17:24:53,877: Connect Active Indication: 
17:24:53,887: Connect Active Response: 0C 00 01 00 03 83 64 05 01 01 00 00 
17:24:53,887: Connect Active Response
17:24:53,887: Connect B3 Request: 0D 00 01 00 82 80 83 02 01 01 00 00 00 
17:24:53,887: Connect B3 Request
17:24:53,897: Connect B3 Confirm: 0E 00 01 00 82 81 83 02 01 01 01 00 00 00 
17:24:53,897: Connect B3 Confirm
17:24:53,897: Connect B3 Active Indication: 0D 00 01 00 83 82 65 05 01 01 01 00 00 
17:24:53,897: Connect B3 Active Indication
17:24:53,927: Connect B3 Active Response: 0C 00 01 00 83 83 65 05 01 01 01 00 
17:24:53,937: Connect B3 Active Response
-------------------------------------------
17:24:53,947: T: 217.10.79.9:5060
ACK sip:498001507090@217.10.67.4 SIP/2.0
Via: SIP/2.0/UDP 62.143.117.XX:61046;branch=z9hG4bK8010b9be7bffd9118016005056c00008
Route: <sip:08001507090@217.10.79.9;ftag=4555;lr=on>
Route: <sip:498001507090@217.10.79.8;ftag=4555;lr=on>
From: r <sip:8007721@sipgate.de>;tag=4555
To: <sip:08001507090@sipgate.de>;tag=as41dc2e51
Call-ID: 808925BB-7BFF-D911-8015-005056C00008@62.143.117.XX
CSeq: 10 ACK
Contact: <sip:8007721@62.143.117.XX:61046>
Max-Forwards: 70
Content-Length: 0
-------------------------------

Nochwas?

Gruß,
  Pfeffer.
  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 11010
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Phoner Lite: kein Ton beim angerufenen
Reply #3 - 30. Jul 2005 at 20:32
Print Post  
Oops! Da hat sich tatsächlich eine furchtbare Verschlimmbesserung eingebaut.
Ab sofort sollte es wieder funktionieren. Die Version läuft immer noch unter 0.8
  
Back to top
WWW  
IP Logged
 
Pfeffer
Guest


Re: Phoner Lite: kein Ton beim angerufenen
Reply #4 - 01. Aug 2005 at 01:35
Print Post  
Quote:
Oops! Da hat sich tatsächlich eine furchtbare Verschlimmbesserung eingebaut.
Ab sofort sollte es wieder funktionieren. Die Version läuft immer noch unter 0.8

Ich habe mir http://www.phoner.de/PhonerLiteSetup.exe erneut installiert - aber habe das gleiche Problem. Die ausgehende rtp-Übertragung bricht laut etherreal-trace nach weniger als 1 Sekunde ab, genauer: nach 10 Paketen.

Gruß,
  Pfeffer.
  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 11010
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Phoner Lite: kein Ton beim angerufenen
Reply #5 - 01. Aug 2005 at 07:14
Print Post  
Du solltest PhonerLite.zp benutzen. Die Setup-Version muss ich noch überarbeiten, dass neuere Versionen ältere überschreiben dürfen...
  
Back to top
WWW  
IP Logged
 
Pfeffer
Guest


Re: Phoner Lite: kein Ton beim angerufenen
Reply #6 - 01. Aug 2005 at 11:04
Print Post  
ahh!

Leider gibt es auf der Download-Seite keinen Link dahin. Aber mit dem jetzt von Dir klappt's (Kommunikation in beide Richtungen) - danke!

Noch ein Vorschlag: In dem Info-Dialog die Build-Version mit anzeigen. Dann kann man auch bei den Betas sehen, ob man nun eine neue hat.

Gruß,
  Pfeffer.
  
Back to top
 
IP Logged
 
hanz
Guest


Re: Phoner Lite: kein Ton beim angerufenen
Reply #7 - 02. Aug 2005 at 23:51
Print Post  
Hi,

der Angerufene hört leider auch bei mir nichts (mit der Light Version). Auch mit der Version aus deinem letzten Posting.
Mit der "Vollversion" von Phoner klappt es.

Hans
  
Back to top
 
IP Logged
 
Suppenkasper
God Member
*****
Offline


Phoner-Support

Posts: 1536
Location: Aachen
Joined: 29. Mar 2005
Gender: Male
Re: Phoner Lite: kein Ton beim angerufenen
Reply #8 - 03. Aug 2005 at 02:16
Print Post  
Hallo Hans,

bitte schick' und doch einmal die Debug-Ausgaben des Phoner-Lite (Anleitung hier, ist zwar für den "großen" Phoner geschrieben, gilt jedoch für den SIP-Modus auch für die LiteVersion).

Ich kann mir nicht vorstellen, dass die Lite-Version nicht funktioniert, jedoch Phoner schon: Beide greifen im SIP-Modus auf die baugleiche sipper.dll zu, und die Codec-Implementerung dürfte auch die gleiche sein.

Nach Deinen Debug-Ausgaben wüßten wir jedoch mehr...

Viele Grüße vom Kai
  
Back to top
IP Logged
 
Hanzz
YaBB Newbies
*
Offline


Phoner is great!

Posts: 1
Joined: 03. Aug 2005
Gender: Male
Re: Phoner Lite: kein Ton beim angerufenen
Reply #9 - 03. Aug 2005 at 19:28
Print Post  
Quote:

Ich kann mir nicht vorstellen, dass die Lite-Version nicht funktioniert, jedoch Phoner schon: Beide greifen im SIP-Modus auf die baugleiche sipper.dll zu, und die Codec-Implementerung dürfte auch die gleiche sein.


Hast recht, lag an meinem Rechner Wink

Sorry Smiley

Vielen Dank für das geniale Programm!
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint