Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic Phoner setzt zu viele '0' vor Rufnummern (Read 1639 times)
Dirk B
YaBB Newbies
*
Offline


Phoner is great!

Posts: 4
Joined: 22. Aug 2018
Phoner setzt zu viele '0' vor Rufnummern
22. Aug 2018 at 16:46
Print Post  
Hallo,

ich habe da ein kleines ärgerliches Problem:
Ich habe meine Rufnummern aus Outlook importiert. Phoner ordnet diese bei eingehenden Anrufen auch korrekt zu.
Leider mag Phoner ausgehende Anrufe scheinbar nicht.

Die Sache gestalltet sich dabei wie folgt (#en stehen für entfernte Rufnummern)
Die importierten Rufnummern haben:
Listenansicht: +49 (VORWAHL) RUFNUMMER
Ländercode: +49
Vorwahl: 2166
Rufnummer: ######

Die ISDN Einstellungen - Standort:

Eigene Vorwahl: 2166
(Rest blieb so)
Nummern Präfix - National: 0
Nummern Präfix - International: 00
Länderkennung: +49
Nebenstelle nicht gesetzt
und 'Ab Anzahl Zeichen' steht nach wie vor auf 2 (was auch immer das sein soll)

PROBLEM:
Ein Anruf an eine Rufnummer innerhalb der selben Vorwahl wird so angewählt:
16:11:27,809: Connect Request: 02166 ###### to 00######
Ein Anruf an eine Mobilfunknummer wird wie folgt gewählt:
16:11:41,330: Connect Request: 02166 ###### to 0001523#######
Es wird also immer eine '00' vorgewählt
Entferne ich aus der Einstellung die internationale Präfix geschieht das:
16:32:02,397: Connect Request: 02166 ###### to +01523#######
Statt der '00' kommt da nun ein '+'.

Kopiere ich nun einen Kontakt in das normale Telefonbuch, sodass ich es bearbeiten kann und entferne dort das Pluszeichen gelingt der Anruf sofort. Da aber, sobald ich 'Eintrag bearbeiten' anklicke, das Pluszeichen automatisch vor den Ländercode gesetzt wird, gehe ich davon aus, das dies so sein soll (deckt sich auch was ich hier gelesen habe).

Ein weitere (und dauerhafter) Workarround ist das Entfernen der Internationalen Präfix und der Länderkennung aus den ISDN Einstellungen (dann gehen die Anrufe in andere Vorwahlgebiete). 
Wählversuche ins eigene Vorwahlgebiet sehen dann so aus:
16:36:35,173: Connect Request: 02166 ###### to +49######
Will ich nun auch noch innerhalb des eigenen Vorwahlgebietes telefonieren, bleibt nur das Entfernen von 'Eigene Vorwahl' und 'Nummern Präfix - National'.

Ich hoffe das Problem ist hier versändlich und das Problem kann schnell gelöst werden, die Fritzbox nervt nämlich wenn ich immer mit Länderkennung anrufe.
  

ISDN-Einstellungen.png ( 8 KB | 65 Downloads )
ISDN-Einstellungen.png
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 9561
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Phoner setzt zu viele '0' vor Rufnummern
Reply #1 - 23. Aug 2018 at 10:49
Print Post  
Kannst du mir bitte (auch per E-Mail) zeigen, wie die importierte Nummer im Telefonbuch genau aussieht? 
Du verwendest die neueste Version von Phoner?
  
Back to top
WWW  
IP Logged
 
Dirk B
YaBB Newbies
*
Offline


Phoner is great!

Posts: 4
Joined: 22. Aug 2018
Re: Phoner setzt zu viele '0' vor Rufnummern
Reply #2 - 23. Aug 2018 at 12:30
Print Post  
Aber gerne doch.
In dem Bild sind die meisten Einträge verwischt. Der nichtverwischte Eintrag ist mein alter Vertrag, der ist aber gekündigt (aktuell, Stand 23.08.2018@12:28, auch nicht vergeben) und dient als Darstellung wie die meisten Einträge aussehen (außer ein paar mit Durchwahl ('-'), aber die muss ich noch ändern).

Als Version ist Phoner 3.20 (heruntergeladen unter http://phoner.de/Phoner.zip) im Einsatz.
  

Outlook-Kontakte-Anon.png ( 301 KB | 63 Downloads )
Outlook-Kontakte-Anon.png
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 9561
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Phoner setzt zu viele '0' vor Rufnummern
Reply #3 - 23. Aug 2018 at 15:47
Print Post  
Schau mal hier: https://forum.phoner.de/cgi-bin/yabb2/YaBB.pl?num=1526627314/
Ist bei dir das Problem in der Beta-Version immer noch vorhanden?
  
Back to top
WWW  
IP Logged
 
Dirk B
YaBB Newbies
*
Offline


Phoner is great!

Posts: 4
Joined: 22. Aug 2018
Re: Phoner setzt zu viele '0' vor Rufnummern
Reply #4 - 23. Aug 2018 at 16:44
Print Post  
Ich habe dazu ein Video und die Debug-Dateien geschickt.

Es ist echt extrem skuril. In dem Video nutze ich die Beta, es ist aber bei der letzten stable genau so.

Wird unter dem Menü Optionen-Kommunikation/Geräte erst die API auf CAPI (nicht auf SIP) gesetzt, mit OK geschlossen, dann wieder geöffnet und auf SIP gesetzt ohne geschlossen zu werden: klappt es - aber nur dann.
Bestätige ich mit OK ist wieder alles ohne Funktion.
  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 9561
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Phoner setzt zu viele '0' vor Rufnummern
Reply #5 - 27. Aug 2018 at 10:43
Print Post  
Das ist in der Tat sehr merkwürdig. Ich kann das momentan bei mir nicht nachvollziehen. Ich kann nur den SIP-Modus testen. 
Ist bei dir die Länderliste geladen(Optionen/ISDN/Ländervorwahlen)?

Ist PhonerLite für dich keine Option?
  
Back to top
WWW  
IP Logged
 
Dirk B
YaBB Newbies
*
Offline


Phoner is great!

Posts: 4
Joined: 22. Aug 2018
Re: Phoner setzt zu viele '0' vor Rufnummern
Reply #6 - 27. Aug 2018 at 11:19
Print Post  
Die Datei wird geladen.

PhonerLite habe ich nur mal kurz angesehen, aber dort nicht die Möglichkeit gefunden Outlook-Kontakte zu importieren. Wenn es da eine Möglichkeit gibt, wäre das natürlich eine gute Lösung.
  

laendervorwahlen.png ( 6 KB | 63 Downloads )
laendervorwahlen.png
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 9561
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Phoner setzt zu viele '0' vor Rufnummern
Reply #7 - 27. Aug 2018 at 13:05
Print Post  
PhonerLite kann KEINE Outlook-Kontakte importieren.
Sorry, ich bin dann momentan leider ratlos.
  
Back to top
WWW  
IP Logged
 
Horst1959
YaBB Newbies
*
Offline


Phoner is great!

Posts: 1
Joined: 11. Feb 2020
Re: Phoner setzt zu viele '0' vor Rufnummern
Reply #8 - 11. Feb 2020 at 14:39
Print Post  
Hallo,
gibt es schon eine Lösung? Bei mir tritt exakt der gleiche Fehler auf. Einschließlich erst die API auf CAPI (nicht auf SIP) setzen, mit OK schließen, wieder öffnen und auf SIP setzten ohne schließen. Dann funktioniert es bis zum bestätigen.
Viele Grüße
Horst
  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 9561
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Phoner setzt zu viele '0' vor Rufnummern
Reply #9 - 11. Feb 2020 at 14:48
Print Post  
Ich selbst habe seit Jahren schon kein Outlook mehr und kann das deshalb nicht testen. Das tritt weiterhin nur bei der Wahl aus den importierten Outlook-Kontakten auf? Die gleiche Nummer im Phoner-Telefonbuch oder manuell eingegeben - das funktioniert?
  
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint