Page Index Toggle Pages: 1 Send TopicPrint
Hot Topic (More than 10 Replies) Answering a call takes 5 seconds (Read 649 times)
webgurupc
YaBB Newbies
*
Offline


Phoner is great!

Posts: 7
Joined: 27. Aug 2018
Answering a call takes 5 seconds
27. Aug 2018 at 02:31
Print Post  
Hi,
Great program. Lots of options. Awesome. Smiley
When a call comes in I click the green answer button once. It then appears to do nothing for about 4 to 5 seconds, then I get another ring. Then it connects the call and I can talk.
--
Extra information
What I hear through the headset immediately after I click the green answer button is silence, as described, (so you think it is connected, and might start saying your "hellos" ) and then after the 4 seconds another ring sound, then that stops and the call is connected when you can actually communicate.
--
I have tried this multiple times. I only press the green answer button once.

I did search the forums, but couldn't find a similar issue.

Thanks.
  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 8997
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Answering a call takes 5 seconds
Reply #1 - 27. Aug 2018 at 11:12
Print Post  
I think you have configured a STUN server. That doesn't seem to be the right one, because there are 5 seconds timeout for communication with the STUN server. Just leave the filed for STUN empty, save the configuration and try again.
  
Back to top
WWWGTalkSkype/VoIP  
IP Logged
 
webgurupc
YaBB Newbies
*
Offline


Phoner is great!

Posts: 7
Joined: 27. Aug 2018
Re: Answering a call takes 5 seconds
Reply #2 - 28. Aug 2018 at 02:32
Print Post  
Thanks . That was it. Smiley
  
Back to top
 
IP Logged
 
cymn
YaBB Newbies
*
Offline


Phoner is great!

Posts: 4
Joined: 25. Sep 2018
Re: Answering a call takes 5 seconds
Reply #3 - 25. Sep 2018 at 16:07
Print Post  
I have the same issue, but i don't have a STUN Server configured.

I noticed that it takes some time until the "in"-codec is used. When i don't "register" against the Proxy/Registrar i don't have any delay in answering calls.
Can you help me too?  Cheesy
  

debug.txt ( 14 KB | 22 Downloads )
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 8997
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Answering a call takes 5 seconds
Reply #4 - 25. Sep 2018 at 16:33
Print Post  
Try to deactivate "QoS" at the configuration/network page. Don't forget to save after such changes.
  
Back to top
WWWGTalkSkype/VoIP  
IP Logged
 
cymn
YaBB Newbies
*
Offline


Phoner is great!

Posts: 4
Joined: 25. Sep 2018
Re: Answering a call takes 5 seconds
Reply #5 - 26. Sep 2018 at 10:20
Print Post  
Phoner Admin wrote on 25. Sep 2018 at 16:33:
Try to deactivate "QoS" at the configuration/network page. Don't forget to save after such changes.

Thanks for your help!

But it doesn't help. Any further suggestions?
  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 8997
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Answering a call takes 5 seconds
Reply #6 - 26. Sep 2018 at 10:49
Print Post  
The problem is, that no speech data (RTP) is received by PhonerLite for 5 seconds. Can you deactivate (just for testing) any firewall or security suite on your PC?
  
Back to top
WWWGTalkSkype/VoIP  
IP Logged
 
cymn
YaBB Newbies
*
Offline


Phoner is great!

Posts: 4
Joined: 25. Sep 2018
Re: Answering a call takes 5 seconds
Reply #7 - 26. Sep 2018 at 17:13
Print Post  
The Firewall was already deaktivated. I although tried some network combination with deaktivated firewall
network -> windows firewall -> checked
network -> windows firewall -> unchecked
didn't made any changes.

i doubt it is my pc-configuration, because if i uncheck "registration" there is nearly instant inbound traffic. 

Maybe the router. It's an Fritzbox 7490 Version 7.01 (up-to-date atm)
  

debug_001.txt ( 24 KB | 23 Downloads )
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 8997
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Answering a call takes 5 seconds
Reply #8 - 27. Sep 2018 at 08:50
Print Post  
I don't have problems with my Fritzbox 7390 here. But for this old device there is no newer (7.xx) firmware available.
Registration fails in your case. So I assume some problem in configuration.
Are you using another phone device (or softphone) that uses the same Fritzbox account)?
  
Back to top
WWWGTalkSkype/VoIP  
IP Logged
 
cymn
YaBB Newbies
*
Offline


Phoner is great!

Posts: 4
Joined: 25. Sep 2018
Re: Answering a call takes 5 seconds
Reply #9 - 27. Sep 2018 at 09:28
Print Post  
Hi PAdmin,
no each PC has it's own account. I just made a new account, same result.

Can't find any suspicious settings in my fritzbox. Any further ideas?

btw thank you so much for your help!
  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 8997
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Answering a call takes 5 seconds
Reply #10 - 27. Sep 2018 at 09:49
Print Post  
You can change the local port in PhonerLite from 5060 to 5070 for example.
If that doesn't help, I can't help you. As lang as I can't reproduce it for my own I can't do nothing. You should use a professional solution than just my simply hobby project maybe.
  
Back to top
WWWGTalkSkype/VoIP  
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint