Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic DNS SRV doesn't seem to work (Read 291 times)
vince
YaBB Newbies
*
Offline


Phoner is great!

Posts: 1
Joined: 20. Aug 2020
DNS SRV doesn't seem to work
20. Aug 2020 at 15:33
Print Post  
I'm trying to register on a server that is set as a second record in the SRV hostname hosted-yvr.something.com. The phonerLite sends requests only to the first one hosted-yvr-one.something.com which replies with "port unreachable", but the phone keeps trying the same one, instead of using the second record in SRV hosted-yvr-three.something.com. (I've changed the host with "something")
Here is the dig output querying the srv hostname

$ dig srv _sip._udp.hosted-yvr.something.com
....
;; ANSWER SECTION:
_sip._udp.hosted-yvr.something.com. 300 IN SRV 1 1 5060 hosted-yvr-one.something.com.
_sip._udp.hosted-yvr.something.com. 300 IN SRV 2 2 5060 hosted-yvr-three.something.com.
....

I'm attaching a packet trace from my test as well as the last part of the debug info from the phone:
  

phonerlite-srv_pcap.txt ( 43 KB | 9 Downloads )
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 10059
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: DNS SRV doesn't seem to work
Reply #1 - 20. Aug 2020 at 15:38
Print Post  
You are right. The DNS/SRV support is not complete. Only the first (highest prio) resolved address is used. Right now I have no time to change that.
  
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint