Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic protocol Error, layer 2 (Read 454 times)
Klaus Hamburg
YaBB Newbies
*
Offline


Phoner is great!

Posts: 5
Location: Hamburg
Joined: 08. Apr 2013
Gender: Male
protocol Error, layer 2
31. Jan 2021 at 12:44
Print Post  
Ich benutze Phoner seit Ende 2012 ohne Probleme.
Aktuelle Version 3.19
Seit kurzem wird aber keine Verbindung aufgebaut.
In der Statusleiste wird zunächst "verbinden" angezeigt, nach kurzer Zeit dann "protocol error layer 2".
Ich verwende eine ISDN-Karte von AVM, die lt. Geräte Manager einwandfrei funktioniert.
Kann mir jemand helfen, den Fehler zu beseitigen?

Logbuch:
B8;(30) 6660678;ab:;nein: protocol error, layer 2;31.01.2021 12:25:51;31.01.2021 12:25:57;;
Debug:
Phoner 3.19
12:25:38,145: OpenDevice (capi2032.dll)
12:25:38,145: LoadCAPI(capi2032.dll)
12:25:38,145: Installed
12:25:38,145: AVM-GmbH: 2.0 (3.11-7)
12:25:38,145: Register: 240 bytes blocksize
12:25:38,145: CAPI thread created: 0x0338
12:25:38,146: LoadISDNEncoderDecoder(sipper.dll)
12:25:38,146: Listen Request
12:25:38,146: Facility Request (Get Supplementary Services)
12:25:38,637: HID out: reset input = 1
12:25:38,639: Standalone: C:\Program Files (x86)\Phoner\phoner.exe
12:25:38,674: Listen Confirm
12:25:38,674: Facility Confirm (Supplementary Services)
12:25:38,675: Status: getrennt
12:25:38,676: Facility Request (Supplementary Services: Forward - Interrogate Numbers)
12:25:38,676: Facility Request (Listen To Supplementary Services)
12:25:38,677:  Get Supported Services: success
12:25:38,677: Facility Confirm (Supplementary Services)
12:25:38,677:  CF Interrogate Numbers: success
12:25:38,678: Facility Confirm (Supplementary Services)
12:25:38,679:  Listen: success
12:25:51,617: active call index=0
12:25:51,617: Status: verbinden
12:25:51,618: Connect Request:  to 0306660678
12:25:51,618: Connect Confirm
12:25:57,653: Disconnect Indication: protocol error, layer 2
12:25:57,654: Status: trennen
12:25:57,907: Status: getrennt
12:25:57,908: Status: protocol error, layer 2
12:25:57,908: active call index=0
12:25:57,909: Disconnect Response
12:30:56,377: Device is still open Smiley
12:30:56,389: Status: getrennt
12:30:56,390: Facility Request (Supplementary Services: Forward - Interrogate Numbers)
12:30:56,406: Facility Confirm (Supplementary Services)
12:30:56,406:  CF Interrogate Numbers: success
12:31:37,735: CloseDevice
12:31:37,736: Listen Request
12:31:37,737: CAPI thread terminating: 0x0338
12:31:37,737: Release
12:31:37,738: UnloadCAPI
12:31:37,739: OpenDevice (capi2032.dll)
12:31:37,739: LoadCAPI(capi2032.dll)
12:31:37,740: Installed
12:31:37,742: AVM-GmbH: 2.0 (3.11-7)
12:31:37,743: Register: 240 bytes blocksize
12:31:37,745: CAPI thread created: 0x030C
12:31:37,746: LoadISDNEncoderDecoder(sipper.dll)
12:31:37,747: Listen Request
12:31:37,747: Facility Request (Get Supplementary Services)
12:31:37,819: Listen Confirm
12:31:37,820: Facility Confirm (Supplementary Services)
12:31:37,843: Facility Request (Supplementary Services: Forward - Interrogate Numbers)
12:31:37,843: Facility Request (Listen To Supplementary Services)
12:31:37,843:  Get Supported Services: success
12:31:37,844: Facility Confirm (Supplementary Services)
12:31:37,844:  CF Interrogate Numbers: success
12:31:37,844: Facility Confirm (Supplementary Services)
12:31:37,845:  Listen: success


  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 10358
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: protocol Error, layer 2
Reply #1 - 01. Feb 2021 at 08:56
Print Post  
Ein solcher "protocol error, layer 2" deutet auf ein Verkabel-Problem hin. Phoner hat da keinen Einfluss drauf. Die ISDN-Karte meldet den Fehler, wenn beispielsweise kein Kabel angeschlossen ist.
  
Back to top
WWW  
IP Logged
 
Klaus Hamburg
YaBB Newbies
*
Offline


Phoner is great!

Posts: 5
Location: Hamburg
Joined: 08. Apr 2013
Gender: Male
Re: protocol Error, layer 2
Reply #2 - 01. Feb 2021 at 14:00
Print Post  
Phoner Admin wrote on 01. Feb 2021 at 08:56:
Ein solcher "protocol error, layer 2" deutet auf ein Verkabel-Problem hin. Phoner hat da keinen Einfluss drauf. Die ISDN-Karte meldet den Fehler, wenn beispielsweise kein Kabel angeschlossen ist.


Vielen herzlichen Dank.
Ich hatte vor einiger Zeit das Kabel ausgetauscht, weil die Rastnase abgebrochen war.
Habe jetzt wieder das alte Kabel angeschlossen und jetzt funktioniert es wieder.
  
Back to top
 
IP Logged
 
Klaus Hamburg
YaBB Newbies
*
Offline


Phoner is great!

Posts: 5
Location: Hamburg
Joined: 08. Apr 2013
Gender: Male
Re: protocol Error, layer 2
Reply #3 - 05. Feb 2021 at 22:53
Print Post  
Nachdem der Aufbau der Telefonverbindung geklappt hat, tritt jetzt ein neuer Fehler auf.
Das Senden von Tastencodes funktioniert nicht.
Ich habe versucht ein "*" zu senden. Ging nicht.
Danach hab ich es mit der "1" versucht. Ging auch nicht.
Woran könnte das liegen. 
Früher ging das problemlos und ich habe an den Einstellungen nichts geändert, allenfalls versehentlich.
In der anhängenden Debug.zip befinden sich die Dateien DebugApp.txt, DebugCapi.txt und DebugISDN.txt
  

Debug_004.zip ( 24 KB | 17 Downloads )
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 10358
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: protocol Error, layer 2
Reply #4 - 08. Feb 2021 at 10:00
Print Post  
Wenn du in Phoner Optionen/Kommunikation/CAPI öffnest, solltest du sehen, ob deine CAPI DTMF unterstützt. Da müsste ein grünes Häkchen rechts in der Liste bei "DTMF supported" stehen.
Desweiteren gibt es auf der gleichen Seite eine Option zum Anhaken namens "eigenes DTMF" Darüber kann man festlegen ob die CAPI den Ton senden/erkennen soll, oder ob das die Applikation selber machen kann. Du kannst also lediglich dieses eine Häkchen setzen oder nicht - mehr kann man da gar nicht umstellen.
  
Back to top
WWW  
IP Logged
 
Klaus Hamburg
YaBB Newbies
*
Offline


Phoner is great!

Posts: 5
Location: Hamburg
Joined: 08. Apr 2013
Gender: Male
Re: protocol Error, layer 2
Reply #5 - 09. Feb 2021 at 15:55
Print Post  
Danke, jetzt funktioniert es.https://forum.phoner.de/public_html/yabbfiles/Templates/Forum/default/smiley.gif

"DTMF supported" hatte ein grünes Häkchen.
"Eigenes DTMF" war markiert. Hab die Markierung entfernt. Danach lief es.
Hab ich wohl versehentlich markiert.
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint