Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic Klingelsound wird nicht abgespielt (Read 2386 times)
Klaus_AB
YaBB Newbies
*
Offline


Phoner ist großartig!

Posts: 10
Location: Aschaffenburg
Joined: 10. May 2006
Gender: Male
Klingelsound wird nicht abgespielt
28. Sep 2017 at 16:37
Print Post  
Hallo,
seit einigen Tagen wird der Klingelsound nicht mehr abgespielt.
(Phoner - Win 10pro)
Die Eintragungen unter Optionen Sound sind auf ein spezielles Gerät und Klingeln über Standard eingestellt. Standard ist ein normaler Lautsprecher.
Über Optionen Klänge kann ich den eingestellten Sound mit der TestTaste auch höhren.
Bei eingehenden Rufen aber nicht. Gesprächstöne sind einwandfrei zu höhren. Auch bei Klingeln über das Telefon-Headset ist nichts zu höhren.
Der Windows Soundmixer ist auch korrekt zugeordnet.

danke für Hinweise
Klaus
  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 10047
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Klingelsound wird nicht abgespielt
Reply #1 - 28. Sep 2017 at 16:48
Print Post  
Ich gehe mal davon aus, dass du ein Headset mit HID-Unterstützung verwendest. Dieses meldet per HID sicherlich auch, dass es klingeln kann (Ringer). Für diesen Fall kommt Phoner mit den beiden Arten von Klingeln nicht gut zurecht.
In PhonerLite kann man diesbezüglich mehr einstellen, beispielsweise das HID-Ringing abschalten. Probier also bitte mal PhonerLite statt Phoner aus, falls du denn Phoner im SIP-Modus laufen hattest.
  
Back to top
WWW  
IP Logged
 
Klaus_AB
YaBB Newbies
*
Offline


Phoner ist großartig!

Posts: 10
Location: Aschaffenburg
Joined: 10. May 2006
Gender: Male
Re: Klingelsound wird nicht abgespielt
Reply #2 - 29. Sep 2017 at 07:21
Print Post  
Danke für die schnelle Hilfe.
Ich habe eine jebra USB-Freisprecheinrichtung.
Ja es läuft im Sip-Modus an einer Asterisk.
Phoner-Lite geht nicht, da kein ComServer.
Aber ich habe jetzt was anderes festgestellt:
-Stelle ich im Phoner die Kommunikation auf default, dann kommt der Klingelton.
-Stelle ich auf das entsprechende Gerät, dann kommt kein Klingelton.
Kann ich eigentlich mit leben, wenn ich das bedenke.

  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 10047
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Klingelsound wird nicht abgespielt
Reply #3 - 29. Sep 2017 at 08:32
Print Post  
PhonerLite hat ebenfalls einen eingebauten COM-Server mit einem sehr einfachen Interface.
Es freut mich, dass du einen Workaround gefunden hast.
  
Back to top
WWW  
IP Logged
 
Klaus_AB
YaBB Newbies
*
Offline


Phoner ist großartig!

Posts: 10
Location: Aschaffenburg
Joined: 10. May 2006
Gender: Male
Re: Klingelsound wird nicht abgespielt
Reply #4 - 05. Oct 2017 at 13:13
Print Post  
Gut zu höhren, dass auch Lite den ComServer hat. Leider kann ich ihn nirgends finden (bzw. nicht mit Delphi ansprechen).Was muss ich installieren, damit das funktioniert.
Beide Versionen sind installiert, muss ich die "alte" deinstallieren. Die TLB ist aber hardcodiert auf die phoner.exe.

Wäre wirklich vorteilhaft zu Lite zu migrieren, da ich auf einmal auch Probleme mit DTMF erkennung habe. (Ging früher auch schon mal - und im Lite geht das auch)

Danke für die tolle Arbeit.


  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 10047
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Klingelsound wird nicht abgespielt
Reply #5 - 05. Oct 2017 at 13:55
Print Post  
Wenn du Probleme mit der DTMF-Erkennung in Phoner hast, schalte bitte die Option "eigenes DTMF" unter Optionen/Kommunikation/CAPI ab.

PhonerLite hat ein anderes COM-Interface. Dass musst du erst einmal registrieren. Wenn du es also benötigst, musst du einmalig "PhonerLite -i" mit Admin-Rechten ausführen.
Danach kannst du die TLB in deiner Entwicklungsumgebung importieren.
  
Back to top
WWW  
IP Logged
 
Klaus_AB
YaBB Newbies
*
Offline


Phoner ist großartig!

Posts: 10
Location: Aschaffenburg
Joined: 10. May 2006
Gender: Male
Re: Klingelsound wird nicht abgespielt
Reply #6 - 05. Oct 2017 at 15:27
Print Post  
Ok nach update und -i steht das Com des Lite nun zur Verfügung. Vielen Dank.

eigenes DTMF ist bereits ausgeschaltet und es ging ja auch früher. Mit dem lite wirds dann hoffentlich sowieso gehen. Zumindest direkt ohne das Com geht es ja auch.

danke
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint