Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic Default Communications Device no longer recognized (Read 1397 times)
Bruce Campbell
YaBB Newbies
*
Offline


Phoner is great!

Posts: 6
Joined: 19. Sep 2017
Default Communications Device no longer recognized
18. Nov 2018 at 20:19
Print Post  
I recently updated to PhonerLite 2.68. My options were set to:

Options->Sound Device->Microphone->Default
Options->Sound Device->Speakers->Default"

After the update to PhonerLite 2.68, my Sennheiser Presence UC headset was no longer recognized as the Default Communications Device -- or at least I assume that is what was happening, as I no longer heard anything in the earphone.

I then uninstalled PhonerLite 2.68 and reinstalled PhonerLite 2.58. The problem disappeared, i.e. I could hear and talk into the headset!

Just to be sure, I uninstalled PhonerLite 2.58 and installed PhonerLite 2.68 again and once again heard nothing in the earphone.

I therefore reverted back to PhonerLite 2.58.

Any idea what could be happening? I made no changes to the Options when moving between versions ...

Best regards,
Bruce
  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 9172
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Default Communications Device no longer recognized
Reply #1 - 19. Nov 2018 at 08:51
Print Post  
I can't reproduce that here. As long as in Windows the default communication device is configured properly, it will be used. I just checked that again.
You can check this too by clicking the microphone and speaker button - they are enabled now and you should hear yourself. This test only works as long there is no call at all.
If you click on the speaker button in PhonerLite with pressed Ctrl key, the Windows sound settings will be opened and you should see the devices and which one is selected as default device.

On PhonerLite you should see something like this when sound devices will be opened:
Code
Select All
08:45:38,258: Open capture sound device: Default
08:45:38,284: capture sound device opened
08:45:38,284: Open render sound device: Default
08:45:38,300: render sound device opened 


Do you get a failure with version 2.68?
  
Back to top
WWW  
IP Logged
 
Bruce Campbell
YaBB Newbies
*
Offline


Phoner is great!

Posts: 6
Joined: 19. Sep 2017
Re: Default Communications Device no longer recognized
Reply #2 - 01. Dec 2018 at 05:02
Print Post  
I don't see "open capture sound device" or "open render sound device" in the log at all.

It does not appear for either version 2.58 or 2.68.

Version 2.68 simply ignores the default communication device. The default device has to be the headset earphones, or I can't hear the conversation. I can even set the default communication device to the speakers. It makes no difference. It is just ignored.

This happens with both of my headsets. One is a Sennheiser Presence UC, the other a Crystal SR2822. 

The only thing the two headsets have in common is that they both work through USB, the Presence UC with a wireless dongle, the Crystall SR2822 wired.

Here are a few other things that are interesting about version 2.68:

If I set the earphones as both the default device and default communication device, then everything works as expected. I hear the music in the earphones and during the call I hear the conversation and the music is muted.

If I set the speakers as both the default device and default communication device, I hear the music from the speakers, but when making a call neither the music or the conversation can be heard on the speakers! It doesn't matter what the default communication device is. The same thing happens.

If I set the default device to my earphones and the default communication device to the speakers, then I hear the music in my earphones, and during a call I hear the conversation in the earphones -- but the music continues to play, as it is *not* muted during the call. This is very strange.
  
Back to top
 
IP Logged
 
Bruce Campbell
YaBB Newbies
*
Offline


Phoner is great!

Posts: 6
Joined: 19. Sep 2017
Re: Default Communications Device no longer recognized
Reply #3 - 01. Dec 2018 at 05:27
Print Post  
I just set my speakers as the default device and default communication device and rebooted my computer. Then I opened PhonerLite. I have attached the Debug Log file.
  

Debug_Log.txt ( 12 KB | 30 Downloads )
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 9172
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Default Communications Device no longer recognized
Reply #4 - 03. Dec 2018 at 10:43
Print Post  
I can't see any output regarding sound devices in the log, because you didn't start any call. Instead of starting a call you can also click on the microphone and speaker button in PhonerLite. After that you should hear yourself.
  
Back to top
WWW  
IP Logged
 
Bruce Campbell
YaBB Newbies
*
Offline


Phoner is great!

Posts: 6
Joined: 19. Sep 2017
Re: Default Communications Device no longer recognized
Reply #5 - 05. Dec 2018 at 02:51
Print Post  
Okay, I thought a video might be better for showing what happens.

Here is the link to the video: https://photos.app.goo.gl/1Zyrkmg8kSLEp94Q6

I click on the microphone and speaker icons as you suggest, and the default sound and rendering devices are opened as you said they would be.

But in PhonerLite 2.68, the sound is sent to the default device instead of the default communications device.

You can see this from the volume bars in the "Sound" window. As I am talking into my headset microphone, you can see the volume bar beside the speakers icon moving, showing that the sound is being sent to the speakers instead of the headset earphone.

I assume that I don't hear anything from the speakers because they are being muted.

This does not happen with version 2.58 ...
  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 9172
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: Default Communications Device no longer recognized
Reply #6 - 05. Dec 2018 at 08:22
Print Post  
I see that it doesn't work at your PC. But I checked it with multiple sound devices here at some PCs and could not reproduce the problem. 
You can select the sound devices explicitly in PhonerLite - then it works?
PhonerLite is just a hobby project - I can't test with all possible environments. I hope you understand that.
  
Back to top
WWW  
IP Logged
 
Bruce Campbell
YaBB Newbies
*
Offline


Phoner is great!

Posts: 6
Joined: 19. Sep 2017
Re: Default Communications Device no longer recognized
Reply #7 - 05. Dec 2018 at 16:18
Print Post  
Yes, I completely understand. I thought this might be interesting to you -- maybe something to do with how USB devices are handled. (But I am sure there are more interesting things to work on in the program Smiley

I will use the settings to explicitly set the microphone and earphone.

Thanks!
Bruce
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint