Page Index Toggle Pages: 1 Send TopicPrint
Normal Topic RTP initially going to wrong address (Read 831 times)
Perplexed24
YaBB Newbies
*
Offline


Phoner is great!

Posts: 2
Joined: 18. May 2022
RTP initially going to wrong address
19. May 2022 at 14:19
Print Post  
Hi,

I am using PhonerLite to call into a SIP server (x.x.x.55).   
The 200 OK response has an SDP pointing to a media server with address x.x.x.75 and rtpport.
At the start of the call, PhonerLite sends RTP to the SIP server at x.x.x.55:rtpport.  After a few seconds, it corrects itself and sends the RTP to x.x.x.75:rtpport as it should.  The trigger for this switchover to the correct address looks to be an incoming RTCP sender report from x.x.x.75.
Any ideas why PhonerLite would initially send RTP to the SIP server address instead of the media server address?   
The SDP in the 200 OK looks fine to me.

Thanks,
John
  
Back to top
 
IP Logged
 
Perplexed24
YaBB Newbies
*
Offline


Phoner is great!

Posts: 2
Joined: 18. May 2022
Re: RTP initially going to wrong address
Reply #1 - 19. May 2022 at 19:48
Print Post  
An update on this issue.
The proxy address I'm calling when this RTP is bad (ie. my SIP server) is x.x.x.55:30060 (yes, I have a sip stack listening on port 30060).
I just noticed that if I call into the SIP Server on port 5060, the RTP is correct.
So, it seems PhonerLite has a problem when the SIP server is on a port other than 5060.

Comments/thoughts?
  
Back to top
 
IP Logged
 
Phoner Admin
YaBB Administrator
*****
Offline



Posts: 10894
Location: Germany
Joined: 12. Oct 2003
Gender: Male
Re: RTP initially going to wrong address
Reply #2 - 20. May 2022 at 08:12
Print Post  
Do you really use the latest version of PhonerLite? If so, please send me the content of the debug window after such call. You can show/hide the debug window via help menu.
  
Back to top
WWW  
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint